Database Software

OCR Level 2 ITQ

Skill Set 4
Forms

By the end of this Skill Set you should be able to:

Create Quick Forms
Use Forms to Maintain Data
Change Forms
Use the Form Wizard
Edit Form Design
Edit Form Properties
Test Data
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Exercise 26 - Forms
Knowledge:
Datasheet View is the default setting for looking at a table. It shows many records
at a time in a fixed format, but for large records in particular it will not show all of the
fields without scrolling. Forms usually show table data information one record at a
time and therefore can usually display all of the fields on the screen at once.
Extra information and functionality can be added to forms, such as graphics, text
and validation. Records can be displayed, amended, added or deleted and forms
can be formatted to change the appearance, order and number of fields displayed,
making them very useful for data maintenance and display.

Activity:
1.

Open the Sales database. Open the Customers table in Datasheet View
and examine the structure. Scrolling will be required to see all the fields in a
record, unless you have a very large screen. Close the Customers table.

2.

Double click the Customer Records form to open it. This form shows all of
the fields from the Customers table, but because it shows only one record at
a time, all fields are visible on the same screen.

3.

Look at the form. This was produced as a quick form and then some extra
formatting was added. Compared to using the original Datasheet View, this is
a better way to add records or examine all the data for a record.

4.

Move the cursor over the Reference field. After a few seconds a text reminder
is displayed. This has been defined in Design View.

5.

Click the drop down arrow in the Class field. A list of allowable values is
displayed. Only one of these values may be selected.

6.

Use the Navigation buttons at the bottom of the form to view other records.

7.

Close the Customer Records form and close the database.
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Exercise 27 - Quick Forms
Knowledge:
Access includes a function to create simple forms quickly, based on any selected
table or query. Once created, the design of the forms produced can be altered in
Design or Layout View.

Activity:
1.

Open the Personnel database. Make sure the Staff table is selected but not
opened.

2.

Select the Create tab, then click the Form button. A quick form is
automatically created based on the selected table, Staff.

Note: When a Quick Form is created there is no input from the user regarding the
appearance of the form. All fields from the table are automatically included.
3.

By default the new form is shown in Layout View with the Format tab
displayed. In this view, data is shown in the fields but fields can also be
added, moved and deleted.

4.

Click the drop down arrow on the View button at the left of the ribbon and
select Design View. No data is displayed in this view, but a full range of
formatting options is available.

5.

Click the drop down arrow on the View button at the left of the Ribbon and
select Form View. No formatting is available in this view, but records may be
entered, deleted and amended. This is the normal user view of a form.

6.

Click the Save button on the Quick Access Toolbar and save the form as
Entry.

7.

Leave the form open for the next exercise.
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Exercise 28 - Using Forms
Knowledge:
Forms can be used to enter, edit and organise records in a database table. Many of
the tools available when working with tables, such as sorting, searching, spell
checking, are also available when using forms.

Activity:
1.

The Entry form created in the previous exercise should be open in Form
View. Look at the Navigation buttons at the bottom of the form. They are the
same as those seen when a table is displayed in Datasheet View.

2.

The first record (Barry Batey) should be displayed. Click the Last record
button, , to display the last record in the table (Andrew Wylie).

3.

Click in the Surname field in the form and click the Ascending sort button,
, from the Sort & Filter group on the Home tab. Now the records are
sorted alphabetically by Surname and the first record is for Mukhtar Ahmed.

4.

Click the Last record button,

5.

Click the Clear All Sorts button,

6.

Records can be filtered in forms. Click in the Grade field for the first record.

7.

Click
from the Sort & Filter group and select equals “M2”.
Only records with grade M2 are now available in the form. The Navigation
buttons show Record 1 of 9.

8.

Click
from the Sort & Filter group and select Clear All Filters
All records are available again (Buttons show Record 1 of 220).

9.

The Find feature (including the use of Wildcards) can be used with forms in
the same way as for tables. Click in the Surname field then click the Find
button from the Home tab. Type heron in the Find What box and set the
other options exactly as shown here.

Access 2007

, to display the record for Dawn Young.

57

, to restore the original record order.

© CiA Training Ltd 2010

Database Software

OCR Level 2 ITQ

Exercise 28 - Continued
10.

Click Find Next to find the first record with a surname of Heron. Move the
Find and Replace dialog box to see the record more clearly.

11.

Type don* in the Find What box, replacing all existing text. The wildcard
symbol * represents any number of unknown characters.

12.

Click Find Next. The first record having a surname starting with the
characters don is found (Donahue).

13.

Click Find Next again. The record for Donaldson is found.

14.

Click Find Next. A message is displayed indicating that Access has finished
searching and no more records were found with a surname starting don.

15.

Click OK. Click Cancel to close the Find and Replace dialog box.

16.

Click the New Record button, either from the Records group of the Home
tab,
, or at the bottom of the screen by the record navigation buttons
. A blank form is displayed to enter details of a new record (record 221).

17.

Type 380 in Staff Number and press <Tab> or <Enter>.

18.

Enter a Surname of Lee, a First Name of Robert, a Sex of M, and a
Department of Sales. Type 8000 in Salary and press <Tab> or <Enter>.

19.

In Exercise 23, a validation criteria was added to the Salary field in the Staff
table. Field validations applied to the table will still apply in a form and a
warning message will be displayed. Click OK.

20.

Change the Salary to 12000 and press <Tab> or <Enter> three times to
complete the new record.

21.

Click the Previous record button,

22.

Double click in the Department field to highlight the existing text, and type
Training.

23.

Mr Lee has left. With his record displayed, click the drop down arrow on the
Delete button in the Records group on the Home tab. Select Delete Record.

24.

Click Yes to confirm the deletion.

25.

Click the Last record button, to confirm that there are again 220 records and
leave the table open for the next exercise.
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Exercise 29 - Removing Fields
Knowledge:
One of the advantages of using forms to maintain data is that not all data fields from
the table need to be made available.

Activity:
1.

The Entry form used in the previous exercise should be open in Form View.
Switch to Design View.

2.

It has been decided that salary should not be entered at the same time as
adding new staff records. Double click in the Salary field to select it. For the
moment, ignore the Property Sheet which opens on the right.

Note: When a quick form is created in Access 2007, all the fields on the form are
linked in a grouped layout. Double click is needed to select a single field
only.
3.

With the Salary field selected, display the Home tab and click Delete in the
Records group.

4.

The field is removed from the form (not the table). Notice that because all of
the fields are linked, the fields below move up automatically to fill the space.

5.

Switch to Form View. Staff records can still be entered using this form, but it
is not possible to add (or see) any salary information.

Note: It would be possible to create a separate form which included only the salary
information. This could be given restricted access.
6.

Close the form. As the design of the form has been altered, there will be a
prompt to save it. Click Yes.

7.

Open the Staff table to confirm that the Salary field is still part of the table.
Close the table.

8.

Close the Personnel database.
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Exercise 30 - Form Wizard
Knowledge:
Another method of creating a form is to use the wizard. This gives step by step help
in the creation of the form and allows more variety in the layout and the format.
Once created, the design of the forms produced can be altered in Design or
Layout View.

Activity:
1.

Open the Invoices database.

2.

Select the Create tab and click on More Forms.

3.

Click Form Wizard from the list.

4.

The first dialog box of the Form Wizard is displayed. Make sure the Orders
table is selected as the source of data (Table/Queries). Selections can be
made from the drop down list when there is more than one table or query in
the database.

5.

Click

to place all of the available fields on the form. A choice of fields

could be made using
instead, if required. By selecting fields individually
in a different order they can be made to appear on the form in that order.

6.

Click Next.
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Exercise 30 - Continued

7.

Click each layout to view the sample. Select Columnar and click Next.

8.

View the various options for the style. Select Foundry and click Next.

9.

Enter Order Entry as the form title and click Finish. The created form is
displayed in Form View. Notice from the Navigation Pane that the form has
already been saved as part of the creation process.

10.

Leave the form displayed for the next exercise.
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Exercise 31 - Editing Form Design
Knowledge:
Once forms have been created by any method, they can be easily edited, e.g. to
change the arrangement or appearance of objects within the form layout.

Activity:
1.

The Order Entry form created in the previous exercise should be open in
Form View. Switch to Design View.

2.

If the Property Sheet panel appears on the right, click the Property Sheet
button in the Tools group of the Design tab to remove it.

3.

In order to allow the form fields to be edited independently, the
automatic layout feature must be disabled. Click in the form, hold
down <Ctrl> and press the <A> key to select all fields. Display the
Arrange tab and click Remove from the Control Layout group.
Click on a blank area of the form to remove the selection.

4.

Notice that on this form, each data item consists of two parts, a Data field on
the right and a corresponding Label on the left. Click in the Order No data
field, move the cursor to the right edge until it becomes a double headed
arrow, then click and drag the edge to the left until the field is about 2cm wide
(use the ruler at the top of the form or the grid lines for guidance).
Label

Data field

5.

Move the cursor over the edge of the Order No data field until it becomes a
four headed arrow then click and drag the whole field to the centre of the data
area. Notice that by default the label moves with the data field.

6.

To move label or field separately, move the cursor over the black square in
the top left of the Order No label for example, then click and drag about 1cm
to the left. Only the label will move.

7.

New items can be added to a form. Select the Design tab and click
on the Label button in the Controls group.

8.

Click and drag with the Label pointer,
, to draw a box about 6cm by 1cm
to the right of the Order No data field (move the data field if necessary).

9.

The cursor should be flashing inside the new box. Type Order numbers
must be obtained from the Sales Office, then click away from the new box
to see the effect.
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Exercise 31 - Continued
10.

The formatting of any object on the form can be changed. Click in the new
label box to select it (indicated by an orange frame).

11.

Look at the Font group on the Design tab. Use the Font drop down arrow to
select a font of Times New Roman.

12.

Select the Italic option.

13.

Click the Font Color drop down arrow and select a Red colour.

Font

Font
Color

Italic

Font
Size

14.

Click in the Order No data field to select it. Use the Font controls to change
the Font Size to 14 and select the Bold option.

15.

As an alternative method of applying some formatting, right click on a blank
part of the main form area to see a list of options.

16.

Move the cursor over Fill/Back Color from the list and select a pale blue
colour.

17.

Switch to Form View to see the effect of the changes.

Note: Remember, any Font effect can be applied to any part of the form.
18.
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Exercise 32 - Form Properties
Knowledge:
Any data validation properties applied to the fields in a table will still apply when
those fields appear in a form. For validation properties that have not been added to
the table, it is possible to add many of them directly to the fields on the form. The
only difference will be that such validations will only be in force on that form.

Activity:
1.

The Order Entry form created in the previous exercise should be open in
Form View. Switch to Design View.

2.

Click in the Date data field to select it then click Property Sheet in
the Tools group of the Design tab. The Property Sheet panel for
the selected field appears on the right of the form design area.

3.

Select the Data tab in the Property Sheet panel. Notice some of the same
validation properties that were seen in table design, such as Default Value
and Validation Rule.

4.

Type =Date() in the Default Value property. This always represents the
current date.

5.

Switch to Form View and click the button to add a new record. Today’s date
will appear in the Date field by default (it can be overwritten).

6.

Switch back to Design View. One way to improve efficiency and data integrity
is to select a value from a list of allowed values, rather than risk a typing
mistake.

7.

Right click in the Type data field and select Delete from the shortcut menu.
The field and its label are removed from the form.

8.

Look in the Controls group of the Design tab and make sure Use Control
Wizards is active,

(orange background).

9.

Click the Combo Box tool
from the same group and click and drag with it
to draw a box about 6cm by 1cm where the Type field used to be.

10.

The first screen of the Combo Box Wizard is displayed. Select the second
option.

11.

Click Next.
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Exercise 32 - Continued
12.

On the next wizard screen, enter the five possible order types in Col1 as
shown below. Press <Tab> after every entry.

13.

Click Next. On the next screen, select the option to Store that value in this
field, and select Type from the drop down list in the box.

14.

Click Next. Enter Type as the label for the combo box and click Finish. The
combo box is added to the form.

15.

Select the Other tab in the Property Sheet panel for this field. In the
ControlTip Text property, type Select from the list only.

16.

Switch to Form View and start a new record.

17.

Move the cursor over the Type field to see the reminder message.

18.

The Type field now has a drop down arrow. Click it to display a list of values.

19.

Click Software. The value is entered without having to type any text.

20.

To remove the new record, click the Delete drop down arrow on the Home
tab and select Delete Record.

21.

Save the form, and leave it open for the next exercise.
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Exercise 33 - Test Data
Knowledge:
Once a form has been created, it is a good practice to check that it is working as
required. One way to do this is to enter test data into the form to make sure it is
handled correctly. As well as the normal, expected type of data, test data should
include ‘extreme’ values to test the operation of the form when mistakes are made
during entry.
Note: In the development of practical databases, the design and use of test data
can be a complex process. This exercise gives some simple examples only.

Activity:
1.

The Order Entry form created in the previous exercises should be open in
Form View. Start a new record.

2.

Leave the Order No field blank and click in the Type field. Enter Special, i.e.
do not use the drop down selection.

3.

Enter ABC Motors as the Company Name, High Fell as the Town and West
as the Region.

4.

Enter -600 as the Amount and leave the Date unchanged.

5.

Close the form - there are no error messages. Open the Orders table. The
record has been added (at the top of the table).

6.

Click in the new record, click the Delete drop down arrow on the Home tab
and select Delete Record.

7.

This test record has highlighted several points which may need addressing.
First, there should be no order records without an Order Number. This is best
fixed in the table properties. Switch to Design View.

8.

With the first field (Order Number) selected, click Primary Key from the
Design tab.
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Exercise 33 - Continued
9.

Save the table and close it.

10.

Open the Order Entry form and switch to Design View.

11.

Only order types from the list should be allowed. Click in the Type field and
display the Property Sheet panel if not already displayed.

12.

Select the Data tab in the Property Sheet panel. Click in the Limit to List
property and use the drop down arrow to change the value to Yes.

Note: The list of available values is shown in the Row Source property. The list
can be edited here if required.
13.

Click in the Amount field on the form. Click in the Validation Rule property
and type >0. Type Positive values only in the Validation Text property.

14.

The entries for the other fields are acceptable (at this Level) so close the
Property Sheet panel and switch to Form View.

15.

Start a new record using the same test data as before. Leave the Order No
blank and click in the Type field. Enter Special and press <Enter>.

16.

There is an error message because the entry is not on the list. There is an
option to add new values to the list but for this exercise click No.

17.

The list is displayed. Click Consultancy to select that entry.>.

18.

Enter Company Name, Town and Region as before.

19.

Enter -600 as the Amount and press <Enter>. The defined validation
message is displayed. Click OK and change the entry to 600. Press <Enter>.

20.

Press <Enter> to accept the date and complete the record. There is another
error message because Order No is the Primary Key for this table and
cannot be blank. Click OK and enter 1108 as the Order No.

21.

Close the form, saving when prompted.

22.

Open the Orders table. The record has been added (at the end of the table).
Click in the new record, click the Delete drop down arrow on the Home tab
and select Delete Record. Click Yes to confirm.

23.

Close the table and the database.
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Exercise 34 - Develop Your Skills
You will find a Develop Your Skills exercise at the end of each Skill Set. Work through
it to ensure you’ve understood the previous exercises.
1.

Open the Club database. Create an automatic form based on the
membership table. What name is given to the form by default?

2.

Use a filter so that only forms for records with a membership Type of SA are
selected. How many are there?

3.

The fee for all SA records is £375. Use the Replace function to change them
all to £350.

4.

Remove the filter, save the form and close it.

5.

Use the Form Wizard to create another form using all of the fields from the
table. Use Columnar layout, any style and add a title of Record Cards.

6.

Switch to Layout View and display the Arrange tab. Select all fields and use
the Remove button to remove the automatic layout feature.

7.

Switch to Design View. Remove the Type field and add a Combo box field to
the right of the Member field. The box will use typed values FA, SA, JM, and
CM. The value will be stored in the Type field and the label will be Type.

8.

Change the Title label to Name and delete the labels for First Name and
Last Name.

9.

Move the fields for First Name and Last Name to the right of the Title field
and reduce the field widths as shown below. Format the Title, First Name
and Last Name fields as 14pt Bold.

10.

Set a Validation Rule for Fee so that only values less than £800 will be
accepted.

11.

Change a property for Type so that only values from the list will be accepted.

12.

Try the form with some test data to check its operation then save the form,
close it and close the database.

Note:

Answers are listed in the Answers section at the end of the guide.
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Summary: Forms
In this Skill Set you have seen how to create and use forms to edit and organise data
records. You will also have seen some methods which aid data editing such as Find
and Replace within a table.
You will also have learnt some ways in which data integrity may be maintained using
primary keys and data validation techniques and been made aware of some of the
problems which may affect the successful maintenance of database information.
Your OCR ITQ evidence must demonstrate your ability to:
•

•

•

Access 2007

Enter, edit and organise data:


select and update fields



create new records



locate and amend records



using wildcards,



search operators



error checking



data validation

Format data entry forms:


field characteristics and layout



colour



lookup fields (using Combo boxes)



alerts/reminders

Use test data to check data meets requirements:


due to field size



data type



validation checks



duplicate records



format



data that does not fit parameters
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